DJI Fly

The DJI Fly app interface was designed to be simplified and ultra-intuitive. Compatible for DJI Mavic 3 Classic, DJI Avata, DJI Mini 3 Pro, DJI Mavic 3, DJI Mini SE, DJI Air 2S, DJI FPV, DJI Mini 2, Mavic Air 2, Mavic Mini.

V 1.8.0

Requires iOS 11.0 or above.

V 1.8.0

Requires Android 6.0 or above.

Supported Mobile Devices

iOS V 1.8.0

Requires iOS 11.0 or above.

  Compatible with iPhone 14 Pro Max, iPhone 14 Pro, iPhone 14 Plus, iPhone 14, iPhone 13 Pro Max, iPhone 13 Pro, iPhone 13, iPhone 13 mini, iPhone 12 Pro Max, iPhone 12 Pro, iPhone 12, iPhone 12 mini, iPhone 11 Pro Max, iPhone 11 Pro, iPhone 11
For older versions: Click to download

Android V 1.8.0

Requires Android 6.0 or above.

  Compatible with Samsung Galaxy S21,Samsung Galaxy S20,Samsung Galaxy S10+,Samsung Galaxy S10,Samsung Galaxy Note20,Samsung Galaxy Note10+ ,Samsung Galaxy Note9,HUAWEI Mate40 Pro,HUAWEI Mate30 Pro,HUAWEI P40 Pro,HUAWEI P30 Pro,HUAWEI P30,Honor 50 Pro,Mi 11,Mi 10,Mi MIX 4,Redmi Note 10,OPPO Find X3,OPPO Reno 4,vivo NEX 3,OnePlus 9 Pro,OnePlus 9,Pixel 6,Pixel 4,Pixel 3 XL